Home > Articles > Cisco > CCNP Routing and Switching

This chapter is from the book

Scenarios

This section presents several examples of DSL access configurations. The scenarios cover the configuration for a DSLAM, a Cisco 6400 UAC NSP, a Cisco 6400 UAC NRP, and a DSL CPE - Cisco 827.

Scenario 8-1: Configuring IRB over DSL

In this scenario, you will configure the DSL solution to support data transport using IRB. When completed, the Cisco 827 should train up with the DSLAM, and you should be able to ping and access all normal network services from a client PC attached to the DSL CPE modem. Figure 8-9 illustrates how these devices are interconnected.

Figure 9Figure 8-9 IRB Lab Scenario

In Example 8-13, the PVC is mapped from the Cisco 827 DSL connection (ATM1/1) to the DSLAM trunking port (ATM0/1).

Example 8-13 ATM PVC Configuration for the Cisco 6160 DSLAM

interface ATM1/1
 description IRB Architecture
 no ip address
 no atm ilmi-keepalive
 atm pvc 1 51 interface ATM0/1 1 51

In Example 8-14, the PVC is configured from the DSLAM to the NSP and NRP. Interface ATM8/0/0 is the network line card, and interface ATM1/0/0 is the NRP.

Example 8-14 ATM PVC Configuration for the NSP

interface ATM8/0/0
 description OC3 connection to lab-6160
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvc 1 51 interface ATM1/0/0 1 51

A bridge group is configured for IP, and a BVI is created for IRB. The BVI becomes the default gateway for the remote device attached to the CPE equipment (which will be in subnet 10.1.121.0/24). A subinterface is created for a PVC to the NSP. (See the NSP configuration. The NSP maps this PVC to another PVC from the DSLAM, which maps to the subscriber PVC.) In this case, the 1/51 PVC is mapped across the NSP to the 6160. The subinterface is also put in the bridge group. Example 8-15 shows the IRB configuration for the NRP.

Example 8-15 IRB Configuration for the NRP

bridge irb
!
interface BVI1
ip address 10.1.121.1 255.255.255.0
no ip directed-broadcast
!
bridge 1 protocol ieee
 bridge 1 route ip
!
interface ATM0/0/0
no ip address
no ip directed-broadcast
!
interface ATM0/0/0.51 point-to-point

description IRB Configuration
no ip directed-broadcast
pvc 1/51
encapsulation aal5snap
!
bridge-group 1

Example 8-16 shows the bridging configuration for the DSL CPE.

Example 8-16 RFC 1483 Bridging Configuration for the Cisco 827

hostname lab-827A
!
ip subnet-zero
no ip routing
!
interface Ethernet0
 ip address 10.1.121.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 1
!
interface atm0
 mac-address 0001.96a4.8fae  <--- MAC Address from Ethernet 0
 ip address 10.1.121.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc 1/51
 encapsulation aal5snap
 !
 bundle-enable
 bridge-group 1
 hold-queue 224 in
!
ip classless
no ip http server
!
bridge 1 protocol ieee

Scenario 8-2: Configuring RBE over DSL

In this scenario, you will configure the DSL solution to support data transport using RBE. When completed, the Cisco 827 should train up with the DSLAM, and you should be able to ping and access all normal network services from a client PC attached to the DSL CPE modem. Figure 8-10 illustrates how these devices are interconnected.

Figure 10Figure 8-10 RBE Scenario

In Example 8-17, the PVC is mapped from the Cisco 827 DSL connection (ATM1/2) to the DSLAM trunking port (ATM0/1).

Example 8-17 ATM PVC Configuration for the Cisco 6160 DSLAM

interface ATM1/2
 description RBE Architecture
 no ip address
 no atm ilmi-keepalive
 atm pvc 1 52 interface ATM0/1 1 52

In Example 8-18, the PVC is configured from the DSLAM to the NSP and NRP. Interface ATM8/0/0 is the network line card, and interface ATM1/0/0 is the NRP.

Example 8-18 ATM PVC Configuration for the NSP

interface ATM8/0/0
 description OC3 connection to lab-6160
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvc 1 52 interface ATM1/0/0 1 52

Example 8-19 shows the RBE configuration for the NRP. You saw the configuration steps in the previous section.

Example 8-19 RBE Configuration for the NRP

interface Loopback1
 ip address 10.1.121.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM0/0/0
no ip address
no ip directed-broadcast

!
interface ATM0/0/0.52 point-to-point
 description RBE Configuration
 ip unnumbered Loopback1
 atm route-bridged ip
 pvc 1/52
 encapsulation aal5snap
!
ip route 10.1.121.2 255.255.255.255 ATM0/0/0.52

Example 8-20 shows the bridging configuration for the DSL CPE. As you can see, the CPE configuration is the same when you configure the IRB over DSL.

Example 8-20 RFC 1483 Bridging Configuration for the Cisco 827

hostname lab-827B
!
ip subnet-zero
no ip routing
!
interface Ethernet0
 ip address 10.1.121.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 1
!
interface atm0
 mac-address 0001.96a4.8fae
 ip address 10.1.121.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc 1/52
 encapsulation aal5snap
 !
 bundle-enable
 bridge-group 1
 hold-queue 224 in
!
ip classless
no ip http server
!
bridge 1 protocol ieee

Scenario 8-3: Configuring PPPoA over DSL

In this scenario, you will configure the DSL solution to support data transport using PPPoA. When completed, the Cisco 827 should train up with the DSLAM, and you should be able to ping and access all normal network services from a client PC attached to the DSL CPE modem. Figure 8-11 illustrates how these devices are interconnected.

Figure 11Figure 8-11 PPPoA Lab Scenario

In Example 8-21, the PVC is mapped from the Cisco 827 DSL connection (ATM1/3) to the DSLAM trunking port (ATM0/1).

Example 8-21 ATM PVC Configuration for the Cisco 6160 DSLAM

interface ATM1/3
 description PPPoA Architecture
 no ip address
 no atm ilmi-keepalive
 atm pvc 1 53 interface ATM0/1 1 53

In Example 8-22, the PVC is configured from the DSLAM to the NSP and NRP. Interface ATM8/0/0 is the network line card, and interface ATM1/0/0 is the NRP.

Example 8-22 ATM PVC Configuration for the NSP

interface ATM8/0/0
 description OC3 connection to lab-6160
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvc 1 53 interface ATM1/0/0 1 53

Example 8-23 shows the PPPoA configuration for the NRP.

Example 8-23 PPPoA Configuration for the NRP

username cisco password 0 cisco
!
interface ATM0/0/0
no ip address
no ip directed-broadcast
!
interface ATM0/0/0.53 point-to-point
 description PPPoA Configuration
 pvc 1/53

 encapsulation aal5mux ppp Virtual-Template1
 !
interface Virtual-Template1
 description PPPoA
 ip unnumbered Ethernet0/0/0
 peer default ip address pool ccnp
 ppp authentication chap pap

Example 8-24 shows the PPPoA configuration for the DSL CPE.

Example 8-24 PPPoA Configuration for the Cisco 827

hostname lab-827C
!
ip subnet-zero
!
interface Ethernet0
 ip address 10.0.0.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc 1/53
 encapsulation aal5mux ppp dialer
 dialer pool-member 1
 !
!
interface Dialer1
 ip address negotiated
 no ip directed-broadcast
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname cisco
 ppp chap password cisco
!
ip classless
!
dialer-list 1 protocol ip permit

When a PPP connection is made, a virtual interface is created, as shown in Example 8-25. The connection is authenticated with PAP/CHAP (using username "cisco" and password "cisco"). IP addresses are negotiated and handed out from the address pool named ccnp.

Example 8-25 Verifying the Virtual Interface

lab-6400NRP#show interface virtual-access 1
Virtual-Access1 is up, line protocol is up
 Hardware is Virtual Access interface
 Description: PPPoA
 Interface is unnumbered. Using address of Ethernet0/0/0 (10.1.1.190)
 MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec,
   reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation PPP, loopback not set
 Keepalive set (10 sec)
 DTR is pulsed for 5 seconds on reset
 LCP Open
 Open: IPCP
 Bound to ATM0/0/0.53 VCD: 3, VPI: 1, VCI: 53
 Cloned from virtual-template: 1
 Last input 00:00:03, output never, output hang never
 Last clearing of "show interface" counters 14:05:57
 Queueing strategy: fifo
 Output queue 0/40, 0 drops; input queue 0/75, 0 drops
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
   10239 packets input, 141642 bytes, 0 no buffer
   Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
   0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
   21626 packets output, 852074 bytes, 0 underruns
   0 output errors, 0 collisions, 0 interface resets
   0 output buffer failures, 0 output buffers swapped out
   0 carrier transitions

Scenario 8-4: Configuring PPPoE over DSL

In this scenario, you will configure the DSL solution to support data transport using PPPoE. When completed, the Cisco 827 should train up with the DSLAM, and you should be able to ping and access all normal network services from a client PC attached to the DSL CPE modem. Figure 8-12 illustrates how these devices are interconnected.

Figure 12Figure 8-12 PPPoE Lab Scenario

In Example 8-26, the PVC is mapped from the Cisco 827 DSL connection (ATM1/4) to the DSLAM trunking port (ATM0/1).

Example 8-26 ATM PVC Configuration for the Cisco 6160 DSLAM

interface ATM1/4
 description PPPoE Architecture
 no ip address
 no atm ilmi-keepalive
 atm pvc 1 54 interface ATM0/1 1 54

In Example 8-27, the PVC is configured from the DSLAM to the NSP and NRP. Interface ATM8/0/0 is the network line card, and interface ATM1/0/0 is the NRP.

Example 8-27 ATM PVC Configuration for the NSP

interface ATM8/0/0
 description OC3 connection to lab-6160
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvc 1 54 interface ATM1/0/0 1 54

Example 8-28 shows the PPPoE configuration for the NRP.

Example 8-28 PPPoE Configuration for the NRP

username cisco password 0 cisco
!
vpdn enable
!
vpdn-group 1
 accept-dialin
 protocol pppoe
 virtual-template 1
interface ATM0/0/0
no ip address
no ip directed-broadcast
!
interface ATM0/0/0.54 point-to-point
 description LAB PPPoE Configuration
 pvc 1/54
 encapsulation aal5snap
 protocol pppoe
 !
interface Virtual-Template1
 description PPPoE
 ip unnumbered Ethernet0/0/0
 ip mtu 1492
 peer default ip address pool ccnp
 ppp authentication chap pap

For PPPoE over DSL, the DSL CPE is also configured for pure RFC 1483 bridging, as shown in Example 8-29.

Example 8-29 RFC 1483 Bridging Configuration for the Cisco 827

hostname lab-827D
!
ip subnet-zero
no ip routing
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 1
!
interface atm0
 mac-address 0001.96a4.8fae
 ip address 10.1.121.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc 1/52
 encapsulation aal5snap
 !
 bundle-enable
 bridge-group 1
 hold-queue 224 in
!
ip classless
no ip http server
!
bridge 1 protocol ieee

When a PPP connection is made, a virtual interface is created, as shown in Example 8-30. The connection is authenticated with PAP/CHAP (using username "cisco" and password "cisco"). IP addresses are negotiated and handed out from the address pool named ccnp.

Example 8-30 Verifying the Virtual Interface

lab-6400NRP#show int Virtual-Access3
Virtual-Access3 is up, line protocol is up
 Hardware is Virtual Access interface
 Description: PPPoE
 Interface is unnumbered. Using address of Ethernet0/0/0 (10.1.1.190)
 MTU 1492 bytes, BW 100000 Kbit, DLY 100000 usec,
   reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation PPP, loopback not set
 Keepalive set (10 sec)
 DTR is pulsed for 5 seconds on reset
 LCP Open
 Open: IPCP

 Bound to ATM0/0/0.54 VCD: 4, VPI: 1, VCI: 54
 Cloned from virtual-template: 1
 Last input 00:00:04, output never, output hang never
 Last clearing of "show interface" counters 00:01:34
 Queueing strategy: fifo
 Output queue 0/40, 0 drops; input queue 0/75, 0 drops
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
   40 packets input, 2923 bytes, 0 no buffer
   Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
   0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
   78 packets output, 6071 bytes, 0 underruns
   0 output errors, 0 collisions, 0 interface resets
   0 output buffer failures, 0 output buffers swapped out
   0 carrier transitions

Pearson IT Certification Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from Pearson IT Certification and its family of brands. I can unsubscribe at any time.

Overview


Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about Pearson IT Certification products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information


To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites; develop new products and services; conduct educational research; and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@informit.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information


Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security


Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children


This site is not directed to children under the age of 13.

Marketing


Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information


If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out


Users can always make an informed choice as to whether they should proceed with certain services offered by Adobe Press. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.pearsonitcertification.com/u.aspx.

Sale of Personal Information


Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents


California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure


Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links


This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact


Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice


We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020