Home > Articles > Cisco > CCNA Routing and Switching

  • Print
  • + Share This
This chapter is from the book

IPv6 Tunnels: Manual Overlay Tunnel

Figure 25-2 illustrates the network topology for the configuration that follows, which shows how IPv6 tunnels are created.

Figure 25-2

Figure 25-2 Network Topology for IPv6 Tunnel Creation

Juneau Router

Router>enable

Moves to privileged mode

Router#configure terminal

Moves to global configuration mode

Router(config)#hostname Juneau

Sets the host name of the router

Juneau(config)#ipv6 unicast-routing

Enables the forwarding of IPv6 unicast datagrams globally on the router

Juneau(config)#interface tunnel0

Moves to tunnel interface configuration mode

Juneau(config-if)#ipv6 address 2001:db8:c003:1104::1/64

Assigns an IPv6 address to this interface

Juneau(config-if)#tunnel source serial 0/0

Specifies the source interface type and number for the tunnel interface

Juneau(config-if)#tunnel destination 10.1.1.2

Specifies the destination IPv4 address for the tunnel interface

Juneau(config-if)#tunnel mode ipv6ip

Defines a manual IPv6 tunnel; specifically, that IPv6 is the passenger protocol and IPv4 is both the encapsulation and protocol for the IPv6 tunnel

Juneau(config-if)#interface fastethernet 0/0

Moves to interface configuration mode

Juneau(config-if)#ipv6 address 2001:db8:c003:111e::1/64

Assigns an IPv6 address to this interface

Juneau(config-if)#no shutdown

Activates the interface

Juneau(config-if)#interface serial 0/0

Moves to interface configuration mode

Juneau(config-if)#ip address 10.1.1.1 255.255.255.252

Assigns an IPv4 address and netmask

Juneau(config-if)#clock rate 56000

Sets the clock rate on interface

Juneau(config-if)#no shutdown

Starts the interface

Juneau(config-if)#exit

Moves to global configuration mode

Juneau(config)#exit

Moves to privileged mode

Juneau#copy running-config startup-config

Saves the configuration to NVRAM

Fairbanks Router

Router>enable

Moves to privileged mode

Router#configure terminal

Moves to global configuration mode

Router(config)#hostname Fairbanks

Sets the host name of the router

Fairbanks(config)#interface tunnel0

Moves to tunnel interface configuration mode

Fairbanks(config-if)#ipv6 address 2001:db8:c003:1104::2/64

Assigns an IPv6 address to this interface

Fairbanks(config-if)#tunnel source serial 0/0

Specifies the source interface type and number for the tunnel interface

Fairbanks(config-if)#tunnel destination 10.1.1.1

Specifies the destination IPv4 address for the tunnel interface

Fairbanks(config-if)#tunnel mode ipv6ip

Defines a manual IPv6 tunnel; specifically, that IPv6 is the passenger protocol and IPv4 is both the encapsulation and protocol for the IPv6 tunnel

Fairbanks(config-if)#interface fastethernet 0/0

Moves to interface configuration mode

Fairbanks(config-if)#ipv6 address 2001:db8:c003:111f::1/64

Assigns an IPv6 address to this interface

Fairbanks(config-if)#no shutdown

Activates the interface

Fairbanks(config-if)#interface serial 0/0

Moves to interface configuration mode

Fairbanks(config-if)#ip address 10.1.1.2 255.255.255.252

Assigns an IPv4 address and netmask

Fairbanks(config-if)#no shutdown

Starts the interface

Fairbanks(config-if)#exit

Moves to global configuration mode

Fairbanks(config)#exit

Moves to privileged mode

Fairbanks#copy running-config startup-config

Saves the configuration to NVRAM

  • + Share This
  • 🔖 Save To Your Account