Home > Articles

Backbone Router Configuration

  • Print
  • + Share This
This document is an addendum to Appendix H, "Configuration Exercise Equipment Requirements and Backbone Configurations," in the Building Scalable Cisco Networks book from Cisco Press. The materials in this document support the supplemental online chapter, "Configuring IS-IS Protocol," which has been provided to you in accordance with the latest Building Scalable Cisco Internetworks (BSCI) objectives.
This chapter is from the book

This chapter is from the book

Backbone Router Configuration

Table H-6 has been modified from the version in the book to include the IS-IS configuration exercise from the supplemental online chapter, "Configuring IS-IS Protocol." The new material has been shaded for your convenience.

Table H-6 When Configurations Should Be Used on the Backbone Routers

Configuration Exercise

Use This Configuration in This Device (Load the Configuration at the Beginning of the Configuration Exercise)

backbone_r1

backbone_r2

Discovering the Network (Chapter 1)

bbr1 discovery.txt

Configuring OSPF for a Single Area (Chapter 3)

bbr1 ospf single.txt

Configuring OSPF for a Single Area in an NBMA Environment (Chapter 3)

Continue to use bbr1

ospf single.txt

Configuring a Multiarea OSPF Network (Chapter 4)

Continue to use bbr1

ospf single.txt

Configuring a Multiarea IS-IS Network (Online IS-IS Supplement)

bbr1 isis.txt

Configuring EIGRP (Chapter 5)

bbr1 eigrp.txt

Configuring EIGRP in an NBMA Environment (Chapter 5)

Continue to use bbr1

eigrp.txt

Configuring BGP (Chapter 6)

bbr1 bgp.txt

Configuring BGP Route Reflectors and Prefix-List Filtering (Chapter 7)

Continue to use bbr1

bgp.txt

Configuring Multihome BGP (Chapter 7)

Continue to use bbr1

bgp.txt

bbr2 bgp

multihome.txt

Configuring Policy-Based Routing (Chapter 8)

Continue to use bbr1

bgp.txt

Continue to use bbr2

bgp multihome.txt

Configuring Route Redistribution Between

OSPF and EIGRP (Chapter 8)

Continue to use bbr1

bgp.txt

Continue to use bbr2

bgp multihome.txt

Super Lab, Part I and Part II (Chapter 9)

bbr1 super.txt

Continue to use bbr2

bgp multihome.txt


Backbone_r1 Configurations

This section provides the text of the configuration files for the backbone_r1 router. The new IS-IS configuration bbr1 isis.txt has been added (see Configuration H-7), and the EIGRP configuration bbr1 eigrp.txt has been modified (see Configuration H-3).

Configuration H-7 bbr1 isis.txt

! 
!backbone_r1 IS-IS multi-area configuration exercise configuration 
! 
! This file is designed to be copied and pasted into a router that already 
! has the previous BSCN configuration files loaded, at the # prompt 
! 
conf t 
! no access-list 1 
no route-map passext 
no router ospf 200 
! 
! 
router isis 
 net 13.1111.2222.3333.00 
 is-type level-2-only 
! 
! 
clns routing 
! 
interface Loopback100 
 ip router isis
!
interface Loopback101
 ip router isis
!
interface Serial1/0
 ip router isis
!
interface Serial1/1
 ip router isis
!
interface Serial1/2
 ip router isis
!
interface Serial1/3
 ip router isis
!
interface Serial1/4
 ip router isis
!
interface Serial1/5
 ip router isis
!
interface Serial1/6
 ip router isis
!
interface Serial1/7
 ip router isis
!
interface Serial2/0
 ip router isis
!
interface Serial2/1
 ip router isis
!
interface Serial2/2
 ip router isis
!
interface Serial2/3
 ip router isis
!
Exit
Exit
copy run start

Configuration H-3 is a modified version of the configuration that appears in the book. This Configuration H-3 replaces the Configuration H-3 in the book. Because the IS-IS configuration exercise is meant to be done before the EIGRP exercise, the router must be configured differently before EIGRP is enabled if you previously worked on the IS-IS configuration exercise. The changes to the configuration are as follows:

  • The IS-IS protocol, instead of the OSPF protocol, is removed from the router.

  • Access list 1 and route map passext are added to the router.

Configuration H-3 Modified bbr1 eigrp.txt

!
!backbone_r1 EIGRP configuration exercise configuration
!
! This file is designed to be copied and pasted into a router that already
! has the previous BSCN configuration files loaded, at the # prompt
!
conf t
!
no router isis
no clns routing
!
access-list 1 permit 172.16.10.0
access-list 1 permit 172.16.11.0
route-map passext permit 10
 match ip address 1
!
router eigrp 200
  redistribute connected metric 10000 100 255 1 1500 route-map passext
  network 10.0.0.0
!
exit
exit
copy run start
  • + Share This
  • 🔖 Save To Your Account