Home > Articles > Cisco > CCNA Security

Advanced ACL Configuration

When working with network devices, one of the simplest methods of controlling traffic is using access control lists (ACL). This article extends on the ‘Basic Access List Configuration’ (insert link) article that covered the basics and how to configure a basic access list. This article reviews the different advanced options that exist when implementing ACLs, including lists using both source and destination address, reflexive ACLs, and time-basic ACLs.
Like this article? We recommend

When working with network devices, one of the simplest methods of controlling traffic is using access control lists (ACL). This article extends on the ‘Basic Access List Configuration’ article that covered the basics and how to configure a basic access list. This article reviews the different advanced options that exist when implementing ACLs, including lists using both source and destination address, reflexive ACLs and time-basic ACLs.

Overview

When trying to control network traffic, it is not often possible to do this with only the source address; this is where more advanced extended ACLs come in. With an extended ACL, it becomes possible to use the source and destination address or network information, as well as a number of other pieces of information, to control traffic. This provides an ACL to be developed that can more specifically target the specific traffic to be filtered. Not only can the list be created to block a specific address or network, but it can be created to block traffic from a specific address or network going to a specific address or network. It is even possible with an extended ACL to define what protocol that is being permitted or denied. As with standard ACLs, there is a specific number range that is used to specify an extended access list; this range is from 100-199 and 2000-2699.

Other advanced ACLs exist (and will also be covered in this article); these include a review of reflexive ACLs and time based ACLs. Reflexive ACLs implement a form of session filtering that can be used to permit traffic back in through an outside interface that was originated inside a network. This is one of many solutions that Cisco offers in their IOS to limit unauthorized traffic into a networking device. Time-based ACLs work the same as other extended ACLs but provide a mechanism that applies the ACL within a specific timeframe. This option is useful in situations where access to the network is only permitted at specific times; for example, during the working day or during a specific event.

Access List Configuration

An extended access list not only provides the ability to match traffic based on the source address but also on a number of other criteria. As the space for this article is limited, the basic options available will be covered; if interested in the full command syntax, visit cisco.com. The command syntax of an extended ACL is as follows:

router(config)#access-list access-list-number {deny | permit} protocol {source source-wildcard |
 host hostname} {destination destination-wildcard | host hostname}
 [time-range time-range-name] [established]

or

router(config)#ip access-list extended {access-list-name}
router(config-ext-nacl)#[sequence-number] {permit | deny} protocol {source source-wildcard |
 host hostname} {destination destination-wildcard | host hostname}
 [time-range time-range-name] [established] [reflect name]
  • When creating an extended ACL, the access-list-number will always be from 100-199 or 2000-2699 as stated above.
  • The choice of the permit or deny action dictates what action is being taken.
  • The protocol parameter is used to set the protocol that is being filtered; the common values include ip, tcp, and udp.
  • The source parameter is the source IP network that is being matched by the ACL.
  • The source-wildcard parameter is used to affect the source addresses being matched by the ACL by masking off the target addresses with an inverse mask.
  • The host hostname parameter is used to match a specific host instead of a network.
  • The destination parameter is the destination IP network that is being matched by the ACL.
  • The destination-wildcard parameter is used to affect the destination addresses being matched by the ACL by masking off the target addresses with an inverse mask; the host hostname operates the same.
  • The time-range time-range-name parameter is used to link a preconfigured time-range with the ACL making it a time based ACL.
  • The established parameter is used to configure a generic form of session filtering when using TCP.
  • The reflect name parameter is used to create a reflexive access list; this parameter is only available with using named ACL configuration mode. This parameter is used along with the evaluate command as shown later in this article.

The second shown method of configuration uses the named ACL configuration; this method allows some additional functionality that does not exist with the original method including the ability to edit individual lines in an ACL. When using a numbered ACL, the whole list must be deleted and reentered in order to make a change.

In order for an ACL to be functional, it must be applied to a specific interface. When being applied, the access list is configured in a specific direction from the perspective of the interface with the options of coming into the interface (in) or going out of the interface (out). The general rule when applying access lists is to apply standard IP access lists as close to the destination as possible and to apply extended access lists as close to the source as possible. The reasoning for this rule is that standard access lists lack granularity; it is better to implement them as close to the destination as possible. Extended access lists have more potential granularity, thus they are better implemented close to the source. The command syntax to apply an ACL is as follows:

router(config-if)#ip access-group {access-list-number | access-list-name} {in | out}

Reflexive access lists allow traffic to be permitted based on an entry in a temporary table. The entries in this table are created when traffic is sourced from an “inside” interface and is going through an “outside” interface. Information about this session is entered into this table and return traffic is monitored. If the returning traffic matches the outbound information recorded in the table it is allowed in through the interface (“outside”); if it does not, it will be denied. For those who are aware of security terminology, a reflexive ACL works similarly to a stateful firewall.

Examples

Examples of configurations of both an extended ACL and a reflective ACL are shown below.

Extended ACL example

Figure 1 shows a simple network topology with a couple different networks.

In this example, an ACL is required to permit the traffic coming from the 10.10.10.0/24 network to the web server at IP address 172.16.1.100/24 on TCP port 80 but deny all other traffic going to the web server. Standard practice says to place an extended ACL as close to the source as possible; however, in this example, traffic is being blocked from several other sources as well that are off different interfaces. If the ACL would be applied at the source interface, the traffic from the other interfaces would not be affected.

The configuration required to setup the ACL in this example is as follows:

router(config)#access-list 100 permit tcp 10.10.10.0 0.0.0.255 host 172.16.1.100 eq 80

Since in this case the access list is supposed to block traffic from all other sources, no other configuration is required as access lists have an implicit deny at the end of them.

The next step would be to apply the ACL onto the correct interface in the appropriate direction. In this case, the best interface to apply the ACL would be on the F0/1 interface outbound. This would restrict all traffic from entering the 172.16.1.0/24 network destined for the web server that did not come from the 10.10.10.0/24 network.

The configuration required to apply the ACL is as follows:

router(config)#interface f0/1
router(config-if)#ip access-group 100 out

Reflexive ACL example

Figure 2 shows a simple network topology that includes an internal network with hosts that access the Internet.

In this example, the goal is to set up a reflexive ACL so that the only traffic that is allowed out the F0/1 interface is TCP traffic, and the only traffic allowed back into the F0/1 interface is TCP traffic that was initiated from the internal network.

The configuration required to setup the ACL in this example is as follows:

router(config)#ip access-list extended out-going
router(config-ext-nacl)#permit tcp any any reflect sample-reflection
router(config)#ip access-list extended in-coming
router(config-ext-nacl)#evaluate sample-reflection

Notice that a named ACL is being used; reflexive ACLs require that a named ACL be used for configuration. These ACLs must be applied to a specific interface; in this case they are both applied to the F0/1 interface.

The configuration required to apply the ACL is as follows:

router(config)#interface f0/1
router(config-if)#ip access-group out-going out
router(config-if)#ip access-group in-coming in

Summary

The options available for extended ACLs are quite numerous, and the examples discussed in this article only cover the basics. Hopefully, the content in this article will allow a good base of understanding. If you are interested in the other options available for extended ACLs, please visit cisco.com.

Pearson IT Certification Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from Pearson IT Certification and its family of brands. I can unsubscribe at any time.

Overview


Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about Pearson IT Certification products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information


To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites; develop new products and services; conduct educational research; and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@informit.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information


Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security


Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children


This site is not directed to children under the age of 13.

Marketing


Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information


If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out


Users can always make an informed choice as to whether they should proceed with certain services offered by Adobe Press. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.pearsonitcertification.com/u.aspx.

Sale of Personal Information


Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents


California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure


Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links


This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact


Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice


We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020