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 4 Changing Workbook 
  Appearance
In this chapter, you will learn how to
✔ Format cells.
✔ Define styles.
✔ Apply workbook themes and Excel table styles.
✔ Make numbers easier to read.
✔ Change the appearance of data based on its value.
✔ Add images to worksheets.

Entering data into a workbook efficiently saves you time, but you must also ensure  
that your data is easy to read. Microsoft Excel 2010 gives you a wide variety of ways  
to make your data easier to understand; for example, you can change the font, character 
size, or color used to present a cell’s contents. Changing how data appears on a work-
sheet helps set the contents of a cell apart from the contents of surrounding cells. The 
simplest example of that concept is a data label. If a column on your worksheet contains 
a list of days, you can easily set apart a label (for example, Day) by presenting it in bold 
type that’s noticeably larger than the type used to present the data to which it refers. To 
save time, you can define a number of custom formats and then apply them quickly 
to the desired cells.

You might also want to specially format a cell’s contents to reflect the value in that cell. 
For example, Lori Penor, the chief operating officer of Consolidated Messenger, might 
want to create a worksheet that displays the percentage of improperly delivered packages 
from each regional distribution center. If that percentage exceeds a threshold, she could 
have Excel display a red traffic light icon, indicating that the center’s performance is out 
of tolerance and requires attention. 
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In this chapter, you’ll learn how to change the appearance of data, apply existing formats 
to data, make numbers easier to read, change data’s appearance based on its value, and 
add images to worksheets.

Practice Files	 Before	you	can	complete	the	exercises	in	this	chapter,	you	need	to	copy	
the	book’s	practice	files	to	your	computer.	The	practice	files	you’ll	use	to	complete	the	
exercises	in	this	chapter	are	in	the	Chapter04	practice	file	folder.	A	complete	list	of	
practice	files	is	provided	in	“Using	the	Practice	Files”	at	the	beginning	of	this	book.

Formatting Cells
Excel spreadsheets can hold and process lots of data, but when you manage numerous 
spreadsheets it can be hard to remember from a worksheet’s title exactly what data is 
kept in that worksheet. Data labels give you and your colleagues information about data 
in a worksheet, but it’s important to format the labels so that they stand out visually. To 
make your data labels or any other data stand out, you can change the format of the 
cells that hold your data.



Most of the tools you need to change a cell’s format can be found on the Home tab. You 
can apply the formatting represented on a button by selecting the cells you want to apply 
the style to and then clicking that button. If you want to set your data labels apart by 
making them appear bold, click the Bold button. If you have already made a cell’s con-
tents bold, selecting the cell and clicking the Bold button will remove the formatting.

Tip	 Deleting	a	cell’s	contents	doesn’t	delete	the	cell’s	formatting.	To	delete	a	selected	cell’s	
formatting,	on	the	Home	tab,	in	the	Editing	group,	click	the	Clear	button	(which	looks	like	an	
eraser),	and	then	click	Clear	Formats.	Clicking	Clear	All	from	the	same	list	will	remove	the	cell’s	
contents	and	formatting.

Buttons in the Home tab’s Font group that give you choices, such as Font Color, have 
an arrow at the right edge of the button. Clicking the arrow displays a list of options 
accessible for that button, such as the fonts available on your system or the colors you 
can assign to a cell.
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Another way you can make a cell stand apart from its neighbors is to add a border around 
the cell. To place a border around one or more cells, select the cells, and then choose the 
border type you want by selecting from the Border list in the Font group. Excel does 
provide more options: To display the full range of border types and styles, in the Border 
list, click More Borders. The Border page of the Format Cells dialog box contains the full 
range of tools you can use to define your cells’ borders.

You can also make a group of cells stand apart from its neighbors by changing its shading, 
which is the color that fills the cells. On a worksheet that tracks total package volume for 
the past month, Lori Penor could change the fill color of the cells holding her data labels 
to make the labels stand out even more than by changing the labels’ text formatting.

Tip	 You	can	display	the	most	commonly	used	formatting	controls	by	right-clicking	a	selected	
range.	When	you	do,	a	Mini	Toolbar	containing	a	subset	of	the	Home	tab	formatting	tools	
appears	above	the	shortcut	menu.

If you want to change the attributes of every cell in a row or column, you can click the 
header of the row or column you want to modify and then select your desired format.



One task you can’t perform by using the tools on the Home tab is to change the stan-
dard font for a workbook, which is used in the Name box and on the formula bar. The 
standard font when you install Excel is Calibri, a simple font that is easy to read on a 
computer screen and on the printed page. If you want to choose another font, click the  
File tab, and then click Options. On the General page of the Excel Options dialog box, set 
the values in the Use This Font and Font Size list boxes to pick your new display font.

Important	 The	new	standard	font	doesn’t	take	effect	until	you	exit	Excel	and	restart	the	
program.

In this exercise, you’ll emphasize a worksheet’s title by changing the format of cell data, 
adding a border to a cell range, and then changing a cell range’s fill color. After those 
tasks are complete, you’ll change the default font for the workbook.

SET UP	 You	need	the	VehicleMileSummary_start	workbook	located	in	your	
Chapter04	practice	file	folder	to	complete	this	exercise.	Start	Excel,	open	the	
VehicleMileSummary_start	workbook,	and	save	it	as	VehicleMileSummary.	Then	
follow	the	steps.	

	 1.	 Click cell D2.

	 2.	 On the Home tab, in the Font group, click the Bold button.

Excel displays the cell’s contents in bold type.

	 3.	 In the Font group, click the Font Size arrow, and then in the list, click 18.

Excel increases the size of the text in cell D2.
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	 4.	 Click cell B5, hold down the Ctrl key, and click cell C4 to select the non-contiguous 
cells.

	 5.	 On the Home tab, in the Font group, click the Bold button.

Excel displays the cells’ contents in bold type.

	 6.	 Select the cell ranges B6:B15 and C5:H5.

	 7.	 In the Font group, click the Italic button.

Excel displays the cells’ contents in italic type.

	 8.	 Select the cell range C6:H15.

	 9.	 In the Font group, click the Border arrow, and then in the list, click Outside 
Borders.

Excel places a border around the outside edge of the selected cells.

	 10.	 Select the cell range B4:H15.

	 11.	 In the Border list, click Thick Box Border.

Excel places a thick border around the outside edge of the selected cells.

	 12.	 Select the cell ranges B4:B15 and C4:H5.

	 13.	 In the Font group, click the Fill Color arrow, and then in the Standard Colors area 
of the color palette, click the yellow button.

Excel changes the selected cells’ background color to yellow.



Troubleshooting	 The	appearance	of	buttons	and	groups	on	the	ribbon	changes	depending	
on	the	width	of	the	program	window.	For	information	about	changing	the	appearance	of	
the	ribbon	to	match	our	screen	images,	see	“Modifying	the	Display	of	the	Ribbon”	at	the	
beginning	of	this	book.

	 14.	 Click the File tab, and then click Options.

The Excel Options dialog box opens.

	 15.	 If necessary, click General to display the General page.

	 16.	 In the When creating new workbooks area, in the Use this font list, click Verdana.

Verdana appears in the Use This Font field.

	 17.	 Click Cancel.

The Excel Options dialog box closes without saving your change.

CLEAN UP	 Save	the	VehicleMileSummary	workbook,	and	then	close	it.
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Defining Styles
As you work with Excel, you will probably develop preferred formats for data labels, 
titles, and other worksheet elements. Instead of adding a format’s characteristics one 
element at a time to the target cells, you can have Excel store the format and recall it 
as needed. You can find the predefined formats by displaying the Home tab, and then  
in the Styles group, clicking Cell Styles.

Clicking a style from the Cell Styles gallery applies the style to the selected cells, 
but Excel also displays a live preview of a format when you point to it. If none of the 
existing styles is what you want, you can create your own style by clicking New Cell 
Style at the bottom of the gallery to display the Style dialog box. In the Style dialog 
box, type the name of your new style in the Style Name field, and then click Format. 
The Format Cells dialog box opens.



After you set the characteristics of your new style, click OK to make your style available 
in the Cell Styles gallery. If you ever want to delete a custom style, display the Cell Styles 
gallery, right-click the style, and then click Delete.

The Style dialog box is quite versatile, but it’s overkill if all you want to do is apply for-
matting changes you made to a cell to the contents of another cell. To do so, use the 
Format Painter button, found in the Home tab’s Clipboard group. Just click the cell that 
has the format you want to copy, click the Format Painter button, and select the target 
cells to have Excel apply the copied format to the target range.

Tip	 If	you	want	to	apply	the	same	formatting	to	multiple	cells	by	using	the	Format	Painter	
button,	double-click	the	Format	Painter	button	and	then	click	the	cells	to	which	you	want	to	
apply	the	formatting.	When	you’re	done	applying	the	formatting,	press	the	Esc	key.

In this exercise, you’ll create a style and apply the new style to a data label. 

SET UP	 You	need	the	HourlyExceptions_start	workbook	located	in	your	Chapter04	
practice	file	folder	to	complete	this	exercise.	Open	the	HourlyExceptions_start	
workbook,	and	save	it	as	HourlyExceptions.	Then	follow	the	steps.	

	 1.	 On the Home tab, in the Styles group, click Cell Styles, and then click New Cell Style.

The Style dialog box opens.
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	 2.	 In the Style name field, type Crosstab Column Heading.

	 3.	 Click the Format button.

The Format Cells dialog box opens.

	 4.	 Click the Alignment tab.



	 5.	 In the Horizontal list, click Center.

Center appears in the Horizontal field.

	 6.	 Click the Font tab.

	 7.	 In the Font style list, click Italic.

The text in the Preview pane appears in italicized text.

	 8.	 Click the Number tab.

The Number page of the Format Cells dialog box is displayed.

	 9.	 In the Category list, click Time.

The available time formats appear.

	 10.	 In the Type pane, click 1:30 PM.

	 11.	 Click OK to save your changes.

The Format Cells dialog box closes, and your new style’s definition appears in the 
Style dialog box.

	 12.	 Click OK.

The Style dialog box closes.

	 13.	 Select cells C4:N4.
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	 14.	 On the Home tab, in the Styles group, click Cell Styles.

Your new style appears at the top of the gallery, in the Custom group.

	 15.	 Click the Crosstab Column Heading style.

Excel applies your new style to the selected cells.

CLEAN UP	 Save	the	HourlyExceptions	workbook,	and	then	close	it.

Applying Workbook Themes and Excel Table Styles
Microsoft Office 2010 includes powerful design tools that enable you to create attractive, 
professional documents quickly. The Excel product team implemented the new design 
capabilities by defining workbook themes and Excel table styles. A theme is a way to 
specify the fonts, colors, and graphic effects that appear in a workbook. Excel comes 
with many themes installed.

To apply an existing workbook theme, display the Page Layout tab. Then, in the Themes 
group, click Themes, and click the theme you want to apply to your workbook. By default, 
Excel applies the Office theme to your workbooks. 



When you want to format a workbook element, Excel displays colors that are available 
within the active theme. For example, selecting a worksheet cell and then clicking the Font 
Color button’s arrow displays a palette of colors you can use. The theme colors appear in 
the top segment of the color palette—the standard colors and the More Colors link, which 
displays the Colors dialog box, appear at the bottom of the palette. If you format workbook 
elements using colors from the Theme Colors area of the color palette, applying a different 
theme changes that object’s colors.
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You can change a theme’s colors, fonts, and graphic effects by displaying the Page Layout 
tab and then, in the Themes group, selecting new values from the Colors, Fonts, and 
Effects lists. To save your changes as a new theme, display the Page Layout tab, and in the 
Themes group, click Themes, and then click Save Current Theme. Use the controls in the 
Save Current Theme dialog box that opens to record your theme for later use. Later, when 
you click the Themes button, your custom theme will appear at the top of the gallery.

Tip	 When	you	save	a	theme,	you	save	it	as	an	Office	Theme	file.	You	can	apply	the	theme	to	
other	Office	2010	documents	as	well.

Just as you can define and apply themes to entire workbooks, you can apply and 
define Excel table styles. You select an Excel table’s initial style when you create it; 
to create a new style, display the Home tab, and in the Styles group, click Format As 
Table. In the Format As Table gallery, click New Table Style to display the New Table 
Quick Style dialog box.



Type a name for the new style, select the first table element you want to format, and 
then click Format to display the Format Cells dialog box. Define the element’s formatting, 
and then click OK. When the New Table Quick Style dialog box reopens, its Preview pane 
displays the overall table style and the Element Formatting area describes the selected 
element’s appearance. Also, in the Table Element list, Excel displays the element’s name 
in bold to indicate it has been changed. To make the new style the default for new Excel 
tables created in the current workbook, select the Set As Default Table Quick Style For 
This Document check box. When you click OK, Excel saves the new table style.

Tip	 To	remove	formatting	from	a	table	element,	click	the	name	of	the	table	element	and	then	
click	the	Clear	button.

In this exercise, you’ll create a new workbook theme, change a workbook’s theme, create 
a new table style, and apply the new style to an Excel table.

SET UP	 You	need	the	HourlyTracking_start	workbook	located	in	your	Chapter04	
practice	file	folder	to	complete	this	exercise.	Open	the	HourlyTracking_start	
workbook,	and	save	it	as	HourlyTracking.	Then	follow	the	steps.	

	 1.	 If necessary, click any cell in the Excel table.

	 2.	 On the Home tab, in the Styles group, click Format as Table, and then click the 
style at the upper-left corner of the Table Styles gallery.

Excel applies the style to the table.

	 3.	 On the Home tab, in the Styles group, click Format as Table, and then click New 
Table Style.

The New Table Quick Style dialog box opens.

	 4.	 In the Name field, type Exception Default.

	 5.	 In the Table Element list, click Header Row.

	 6.	 Click Format.

The Format Cells dialog box opens.
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	 7.	 Click the Fill tab.

The Fill page is displayed.

	 8.	 In the first row of color squares, just below the No Color button, click the third 
square from the left.

The new background color appears in the Sample pane of the dialog box.

	 9.	 Click OK.



The Format Cells dialog box closes. When the New Table Quick Style dialog box 
reopens, the Header Row table element appears in bold, and the Preview pane’s 
header row is shaded.

	 10.	 In the Table Element list, click Second Row Stripe, and then click Format.

The Format Cells dialog box opens.

	 11.	 Just below the No Color button, click the third square from the left again.

The new background color appears in the Sample pane of the dialog box.

	 12.	 Click OK.

The Format Cells dialog box closes. When the New Table Quick Style dialog box 
reopens, the Second Row Stripe table element appears in bold, and every second 
row is shaded in the Preview pane.

	 Applying	Workbook	Themes	and	Excel	Table	Styles	 	 99



100  	 Chapter	4	 Changing	Workbook	Appearance

	 13.	 Click OK.

The New Table Quick Style dialog box closes.

	 14.	 On the Home tab, in the Styles group, click Format as Table. In the gallery, in the 
Custom area, click the new format.

Excel applies the new format.

	 15.	 On the Page Layout tab, in the Themes group, click the Fonts arrow, and then in 
the list, click Verdana.

Excel changes the theme’s font to Verdana (which is part of the Aspect font set).

	 16.	 In the Themes group, click the Themes button, and then click Save Current 
Theme.

The Save Current Theme dialog box opens.



	 17.	 In the File name field, type Verdana Office, and then click Save.

Excel saves your theme.

	 18.	 In the Themes group, click the Themes button, and then click Origin.

Excel applies the new theme to your workbook.

CLEAN UP	 Save	the	HourlyTracking	workbook,	and	then	close	it.

Making Numbers Easier to Read
Changing the format of the cells in your worksheet can make your data much easier to read, 
both by setting data labels apart from the actual data and by adding borders to define the 
boundaries between labels and data even more clearly. Of course, using formatting options 
to change the font and appearance of a cell’s contents doesn’t help with idiosyncratic data 
types such as dates, phone numbers, or currency values.
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As an example, consider U.S. phone numbers. These numbers are 10 digits long and have 
a 3-digit area code, a 3-digit exchange, and a 4-digit line number written in the form (###) 
###-####. Although it’s certainly possible to type a phone number with the expected for-
matting in a cell, it’s much simpler to type a sequence of 10 digits and have Excel change 
the data’s appearance.

You can tell Excel to expect a phone number in a cell by opening the Format Cells 
dialog box to the Number page and displaying the formats available for the Special 
category.

Clicking Phone Number in the Type list tells Excel to format 10-digit numbers in the 
standard phone number format. You can see this in operation if you compare the con-
tents of the active cell and the contents of the formula box for a cell with the Phone 
Number formatting.



Troubleshooting	 If	you	type	a	9-digit	number	in	a	field	that	expects	a	phone	number,	you	
won’t	see	an	error	message;	instead,	you’ll	see	a	2-digit	area	code.	For	example,	the	number	
425550012	would	be	displayed	as	(42)	555-0012.	An	11-digit	number	would	be	displayed	with	
a	4-digit	area	code.	If	the	phone	number	doesn’t	look	right,	you	probably	left	out	a	digit	or	
included	an	extra	one,	so	you	should	make	sure	your	entry	is	correct.

Just as you can instruct Excel to expect a phone number in a cell, you can also have it 
expect a date or a currency amount. You can make those changes from the Format Cells 
dialog box by choosing either the Date category or the Currency category. The Date 
category enables you to pick the format for the date (and determine whether the date’s 
appearance changes due to the Locale setting of the operating system on the computer 
viewing the workbook). In a similar vein, selecting the Currency category displays controls 
to set the number of places after the decimal point, the currency symbol to use, and the 
way in which Excel should display negative numbers.

Tip	 The	Excel	user	interface	enables	you	to	make	the	most	common	format	changes	by	
displaying	the	Home	tab	of	the	ribbon	and	then,	in	the	Number	group,	either	clicking	a	
button	representing	a	built-in	format	or	selecting	a	format	from	the	Number	Format	list.

You can also create a custom numeric format to add a word or phrase to a number 
in a cell. For example, you can add the phrase per month to a cell with a formula that 
calculates average monthly sales for a year to ensure that you and your colleagues will 
recognize the figure as a monthly average. To create a custom number format, click the 
Home tab, and then click the Number dialog box launcher (found at the bottom right 
corner of the Number group on the ribbon) to display the Format Cells dialog box. 
Then, if necessary, click the Number tab.

In the Category list, click Custom to display the available custom number formats in the 
Type list. You can then click the base format you want and modify it in the Type box. For 
example, clicking the 0.00 format causes Excel to format any number in a cell with two 
digits to the right of the decimal point.

Tip	 The	zeros	in	the	format	indicate	that	the	position	in	the	format	can	accept	any	number	as	
a	valid	value.
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To customize the format, click in the Type box and add any symbols or text you want to 
the format. For example, typing a dollar ($) sign to the left of the existing format and then 
typing “per month” (including quote marks) to the right of the existing format causes the 
number 1500 to be displayed as $1500.00 per month.

Important	 You	need	to	enclose	any	text	to	be	displayed	as	part	of	the	format	in	quotes	so	
that	Excel	recognizes	the	text	as	a	string	to	be	displayed	in	the	cell.

In this exercise, you’ll assign date, phone number, and currency formats to ranges of cells. 

SET UP	 You	need	the	ExecutiveSearch_start	workbook	located	in	your	Chapter04	
practice	file	folder	to	complete	this	exercise.	Open	the	ExecutiveSearch_start	
workbook,	and	save	it	as	ExecutiveSearch.	Then	follow	the	steps.	

	 1.	 Click cell A3.

	 2.	 On the Home tab, click the Font dialog box launcher.

The Format Cells dialog box opens.

	 3.	 If necessary, click the Number tab.

	 4.	 In the Category list, click Date.

The Type list appears with a list of date formats.

	 5.	 In the Type list, click 3/14/01.



	 6.	 Click OK to assign the chosen format to the cell.

Excel displays the contents of cell A3 to reflect the new format.

	 7.	 Click cell G3.

	 8.	 On the Home tab, in the Number group, click the Number Format button’s down 
arrow and then click More Number Formats.

	 9.	 If necessary, click the Number tab in the Format Cells dialog box.

	 10.	 In the Category list, click Special.

The Type list appears with a list of special formats.

	 11.	 In the Type list, click Phone Number, and then click OK.

Excel displays the contents of the cell as (425) 555-0102, matching the format you 
selected, and the Format Cells dialog box closes.

	 12.	 Click cell H3.

	 13.	 Click the Font dialog box launcher.

	 14.	 If necessary, click the Number tab in the Format Cells dialog box.

	 15.	 In the Category list, click Custom.

The contents of the Type list are updated to reflect your choice.
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	 16.	 In the Type list, click the #,##0 item.

#,##0 appears in the Type box.

	 17.	 In the Type box, click to the left of the existing format, and type $. Then click to 
the right of the format, and type “ before bonuses” (note the space after the 
opening quote).

	 18.	 Click OK to close the dialog box.

CLEAN UP	 Save	the	ExecutiveSearch	workbook,	and	then	close	it.

Changing the Appearance of Data  
Based on Its Value

Recording package volumes, vehicle miles, and other business data in a worksheet enables 
you to make important decisions about your operations. And as you saw earlier in this 
chapter, you can change the appearance of data labels and the worksheet itself to make 
interpreting your data easier.

Another way you can make your data easier to interpret is to have Excel change the 
appearance of your data based on its value. These formats are called conditional for-
mats because the data must meet certain conditions, defined in conditional formatting 
rules, to have a format applied to it. For example, if chief operating officer Lori Penor 
wanted to highlight any Thursdays with higher-than-average weekday package volumes, 
she could define a conditional format that tests the value in the cell recording total sales 
and changes the format of the cell’s contents when the condition is met.

To create a conditional format, you select the cells to which you want to apply the format, 
display the Home tab, and then in the Styles group, click Conditional Formatting to display 
a menu of possible conditional formats. In Excel, you can define conditional formats that 
change how the program displays data in cells that contain values above or below the aver-
age values of the related cells, that contain values near the top or bottom of the value range, 
or that contain values duplicated elsewhere in the selected range.



When you select which kind of condition to create, Excel displays a dialog box that contains 
fields and controls you can use to define your rule. To display all of the rules for the selected 
cells, display the Home tab, and then in the Styles group, click Conditional Formatting. On 
the menu, click Manage Rules to display the Conditional Formatting Rules Manager.

The Conditional Formatting Rules Manager enables you to control your conditional formats 
in the following ways:

● Create a new rule by clicking the New Rule button.

● Change a rule by clicking the rule and then clicking the Edit Rule button.

● Remove a rule by clicking the rule and then clicking the Delete Rule button.

● Move a rule up or down in the order by clicking the rule and then clicking the 
Move Up button or Move Down button.

● Control whether Excel continues evaluating conditional formats after it finds a rule 
to apply by selecting or clearing a rule’s Stop If True check box.

● Save any new rules and close the Conditional Formatting Rules Manager by 
clicking OK.

● Save any new rules without closing the Conditional Formatting Rules Manager by 
clicking Apply.

● Discard any unsaved changes by clicking Cancel.

Tip	 Clicking	the	New	Rule	button	in	the	Conditional	Formatting	Rules	Manager	opens	the	
New	Formatting	Rule	dialog	box.	The	commands	in	the	New	Formatting	Rule	dialog	box	
duplicate	the	options	displayed	when	you	click	the	Conditional	Formatting	button	in	the	
Styles	group	on	the	Home	tab.
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After you create a rule, you can change the format applied if the rule is true by clicking 
the rule and then clicking the Edit Rule button to display the Edit Formatting Rule dialog 
box. In that dialog box, click the Format button to display the Format Cells dialog box. 
After you define your format, click OK to display the rule.

Important	 Excel	doesn’t	check	to	make	sure	that	your	conditions	are	logically	consistent,	so	
you	need	to	be	sure	that	you	plan	and	enter	your	conditions	correctly.

Excel also enables you to create three other types of conditional formats: data bars, 
color scales, and icon sets. Data bars summarize the relative magnitude of values in a 
cell range by extending a band of color across the cell.

You can create two types of data bars in Excel 2010: solid fill and gradient fill. When  
data bars were introduced in Excel 2007, they filled cells with a color band that decreased  
in intensity as it moved across the cell. This gradient fill pattern made it a bit difficult to 
determine the relative length of two data bars because the end points weren’t as distinct 
as they would have been if the bars were a solid color. Excel 2010 enables you to choose 
between a solid fill pattern, which makes the right edge of the bars easier to discern, 



and a gradient fill, which you can use if you share your workbook with colleagues who 
use Excel 2007.

Excel also draws data bars differently than was done in Excel 2007. Excel 2007 drew a very 
short data bar for the lowest value in a range and a very long data bar for the highest 
value. The problem was that similar values could be represented by data bars of very 
different lengths if there wasn’t much variance among the values in the conditionally 
formatted range. In Excel 2010, data bars compare values based on their distance from 
zero, so similar values are summarized using data bars of similar lengths.

Tip	 Excel	2010	data	bars	summarize	negative	values	by	using	bars	that	extend	to	the	left	of	
a	baseline	that	the	program	draws	in	a	cell.	You	can	control	how	your	data	bars	summarize	
negative	values	by	clicking	the	Negative	Value	And	Axis	button,	which	can	be	accessed	from	
either	the	New	Formatting	Rule	dialog	box	or	the	Edit	Formatting	Rule	dialog	box.

Color scales compare the relative magnitude of values in a cell range by applying colors 
from a two-color or three-color set to your cells. The intensity of a cell’s color reflects the 
value’s tendency toward the top or bottom of the values in the range.

Icon sets are collections of three, four, or five images that Excel displays when certain 
rules are met. 

When icon sets were introduced in Excel 2007, you could apply an icon set as a whole, 
but you couldn’t create custom icon sets or choose to have Excel 2007 display no icon if 
the value in a cell met a criterion. In Excel 2010, you can display any icon from any set for 
any criterion or display no icon.

When you click a color scale or icon set in the Conditional Formatting Rules Manager 
and then click the Edit Rule button, you can control when Excel applies a color or icon 
to your data.
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Important	 Be	sure	to	not	include	cells	that	contain	summary	formulas	in	your	conditionally	
formatted	ranges.	The	values,	which	could	be	much	higher	or	lower	than	your	regular	cell	
data,	could	throw	off	your	comparisons.

In this exercise, you’ll create a series of conditional formats to change the appearance of 
data in worksheet cells displaying the package volume and delivery exception rates of a 
regional distribution center.

SET UP	 You	need	the	Dashboard_start	workbook	located	in	your	Chapter04	practice	
file	folder	to	complete	this	exercise.	Open	the	Dashboard_start	workbook,	and	save	it	
as	Dashboard.	Then	follow	the	steps.	

	 1.	 Select cells C4:C12.

	 2.	 On the Home tab, in the Styles group, click Conditional Formatting. On the menu, 
point to Color Scales, and then in the top row of the palette, click the second pattern 
from the left.

Excel formats the selected range.

	 3.	 Select cells F4:F12.



	 4.	 On the Home tab, in the Styles group, click Conditional Formatting. On the 
menu, point to Data Bars, and then, in the Solid Fill group, click the orange data 
bar format.

Excel formats the selected range.

	 5.	 Select cells I4:I12.

	 6.	 On the Home tab, in the Styles group, click Conditional Formatting. On the 
menu, point to Icon Sets, and then in the left column of the list of formats, click 
the three traffic lights with black borders.

Excel formats the selected cells.

	 7.	With the range I4:I12 still selected, on the Home tab, in the Styles group, click 
Conditional Formatting, and then click Manage Rules.

The Conditional Formatting Rules Manager opens.

	 8.	 Click the Icon Set rule, and then click Edit Rule.

The Edit Formatting Rule dialog box opens.
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	 9.	 Click the Reverse Icon Order button.

Excel reconfigures the rules so the red light icon is at the top and the green light 
icon is at the bottom.

	 10.	 In the red light icon’s row, in the Type list, click Number.

	 11.	 In the red light icon’s Value field, type 0.7.

	 12.	 In the yellow light icon’s row, in the Type list, click Number.

	 13.	 In the yellow light icon Value field, type 0.5.

	 14.	 Click OK twice to close the Edit Formatting Rule dialog box and the Conditional 
Formatting Rules Manager.

Excel formats the selected cell range.

	 15.	 Click cell C15.

	 16.	 On the Home tab, in the Styles group, click Conditional Formatting. On the 
menu, point to Highlight Cells Rules, and then click Less Than.

The Less Than dialog box opens.

	 17.	 In the left field, type 96%.

	 18.	 In the With list, click Red text.



	 19.	 Click OK.

The Less Than dialog box closes, and Excel displays the text in cell C15 in red.

CLEAN UP	 Save	the	Dashboard	workbook,	and	then	close	it.

Adding Images to Worksheets
Establishing a strong corporate identity helps customers remember your organization  
as well as the products and services you offer. Setting aside the obvious need for sound 
management, two important physical attributes of a strong retail business are a well-
conceived shop space and an eye-catching, easy-to-remember logo. After you or your 
graphic artist has created a logo, you should add the logo to all your documents, especially 
any that might be seen by your customers. Not only does the logo mark the documents 
as coming from your company but it also serves as an advertisement, encouraging anyone 
who sees your worksheets to call or visit your company.

One way to add a picture to a worksheet is to display the Insert tab, and then in the 
Illustrations group, click Picture. Clicking Picture displays the Insert Picture dialog box, 
from which you can locate the picture you want to add from your hard disk. When you 
insert a picture, the Picture Tools Format contextual tab appears on the ribbon. You can 
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use the tools on the Format contextual tab to change the picture’s contrast, brightness, 
and other attributes. With the controls in the Picture Styles group, you can place a bor-
der around the picture, change the picture’s shape, or change a picture’s effects (such as 
shadow, reflection, or three-dimensional effects). Other tools, found in the Arrange and 
Size groups, enable you to rotate, reposition, and resize the picture. 

You can also resize a picture by clicking it and then dragging one of the handles that 
appears on the graphic. If you accidentally resize a graphic by dragging a handle, just 
click the Undo button to remove your change. 

Excel 2010 includes a new built-in capability that you can use to remove the background 
of an image you insert into a workbook. To do so, click the image and then, on the Format 
contextual tab of the ribbon, in the Adjust group, click Remove Background. When you do, 
Excel attempts to identify the foreground and background of the image. 



You can drag the handles on the inner square of the background removal tool to change  
how the tool analyzes the image. When you have adjusted the outline to identify 
the elements of the image you want to keep, click the Keep Changes button on the 
Background Removal contextual tab of the ribbon to complete the operation.

If you want to generate a repeating image in the background of a worksheet to form a 
tiled pattern behind your worksheet’s data, you can display the Page Layout tab, and 
then in the Page Setup group, click Background. In the Sheet Background dialog box, 
click the image that you want to serve as the background pattern for your worksheet, 
and click OK.

Tip	 To	remove	a	background	image	from	a	worksheet,	display	the	Page	Layout	tab,	and	then	
in	the	Page	Setup	group,	click	Delete	Background.

To achieve a watermark-type effect with words displayed behind the worksheet data, save 
the watermark information as an image, and then use the image as the sheet background; 
you could also insert the image in the header or footer, and then resize or scale it to  
position the watermark information where you want it.

In this exercise, you’ll add an image to an existing worksheet, change its location on 
the worksheet, reduce the size of the image, and then set another image as a repeating 
background for the worksheet.
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SET UP	 You	need	the	CallCenter_start	workbook	and	the	phone	and	texture	images	
located	in	your	Chapter04	practice	file	folder	to	complete	this	exercise.	Open	the	
CallCenter_start	workbook,	and	save	it	as	CallCenter.	Then	follow	the	steps.	

	 1.	 On the Insert tab, in the Illustrations group, click Picture.

The Insert Picture dialog box opens.

	 2.	 Navigate to the Chapter04 practice file folder, and then double-click the phone 
image file.

The image appears on your worksheet.

	 3.	 On the Format contextual tab, in the Adjust group, click Remove Background.

Excel attempts to separate the image’s foreground from its background.

	 4.	 Drag the handles at the upper-left and bottom-right corners of the outline until 
the entire phone, including the cord, is within the frame.

	 5.	 On the Background Removal tab, click Keep Changes.

Excel removes the highlighted image elements.



	 6.	 Move the image to the upper-left corner of the worksheet, click and hold the handle 
at the lower-right corner of the image, and drag it up and to the left until the image 
no longer obscures the Call Volume label.

	 7.	 On the Page Layout tab, in the Page Setup group, click Background.

The Sheet Background dialog box opens.

	 8.	 Navigate to the Chapter04 practice file folder, and then double-click the texture 
image file.

Excel repeats the image to form a background pattern.
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	 9.	 On the Page Layout tab, in the Page Setup group, click Delete Background.

Excel removes the background image.

CLEAN UP	 Save	the	CallCenter	workbook,	and	then	close	it.	If	you	are	not	continuing	
directly	to	the	next	chapter,	exit	Excel.



Key Points
● If you don’t like the default font in which Excel displays your data, you can change it.

● You can use cell formatting, including borders, alignment, and fill colors, to 
emphasize certain cells in your worksheets. This emphasis is particularly useful 
for making column and row labels stand out from the data.

● Excel comes with a number of existing styles that enable you to change the 
appearance of individual cells. You can also create new styles to make format-
ting your workbooks easier.

● If you want to apply the formatting from one cell to another cell, use the Format 
Painter to copy the format quickly.

● There are quite a few built-in document themes and Excel table formats you can 
apply to groups of cells. If you see one you like, use it and save yourself lots of 
formatting time.

● Conditional formats enable you to set rules so that Excel changes the appearance 
of a cell’s contents based on its value.

● Adding images can make your worksheets more visually appealing and make your 
data easier to understand. Excel 2010 greatly enhances your ability to manage 
your images without leaving Excel.
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 9 Creating Dynamic 
  Worksheets by Using  
  PivotTables
In this chapter, you will learn how to
✔ Analyze data dynamically by using PivotTables.
✔ Filter, show, and hide PivotTable data.
✔ Edit PivotTables.
✔ Format PivotTables.
✔ Create PivotTables from external data.

When you create Microsoft Excel 2010 worksheets, you must consider how you want the 
data to appear when you show it to your colleagues. You can change the formatting of 
your data to emphasize the contents of specific cells, sort and filter your worksheets based 
on the contents of specific columns, or hide rows containing data that isn’t relevant to the 
point you’re trying to make.

One limitation of the standard Excel worksheet is that you can’t easily change how 
the data is organized on the page. For example, in a worksheet in which each column 
represents an hour in the day, each row represents a day in a month, and the body of 
the worksheet contains the total sales for every hourly period of the month, you can’t 
change the worksheet quickly so that it displays only sales on Tuesdays during the 
afternoon.

There is an Excel tool with which you can create worksheets that can be sorted, filtered, 
and rearranged dynamically to emphasize different aspects of your data. That tool is the 
PivotTable.
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In this chapter, you’ll learn how to create and edit PivotTables from an existing work-
sheet, focus your PivotTable data using filters and Slicers, format PivotTables, and  
create a PivotTable with data imported from a text file.

Practice Files	 Before	you	can	complete	the	exercises	in	this	chapter,	you	need	to	copy	
the	book’s	practice	files	to	your	computer.	The	practice	files	you’ll	use	to	complete	the	
exercises	in	this	chapter	are	in	the	Chapter09	practice	file	folder.	A	complete	list	of	
practice	files	is	provided	in	“Using	the	Practice	Files”	at	the	beginning	of	this	book.

Analyzing Data Dynamically by Using PivotTables
With Excel worksheets you can gather and present important data, but the standard work-
sheet can’t be changed from its original configuration easily. As an example, consider a 
worksheet that records monthly package volumes for each of nine distribution centers in 
the United States. 

Troubleshooting	 The	appearance	of	buttons	and	groups	on	the	ribbon	changes	depending	
on	the	width	of	the	program	window.	For	information	about	changing	the	appearance	of	
the	ribbon	to	match	our	screen	images,	see	“Modifying	the	Display	of	the	Ribbon”	at	the	
beginning	of	this	book.



The data in the worksheet is organized so that each row represents a distribution center 
and each column represents a month of the year. When presented in this arrangement, 
the monthly totals for all centers and the yearly total for each distribution center are 
given equal billing: neither set of totals stands out.

Such a neutral presentation of your data is versatile, but it has limitations. First, although 
you can use sorting and filtering to restrict the rows or columns shown, it’s difficult to 
change the worksheet’s organization. For example, in this worksheet, you can’t easily 
reorganize the contents of your worksheet so that the months are assigned to the rows 
and the distribution centers are assigned to the columns.

The Excel tool to reorganize and redisplay your data dynamically is the PivotTable. You 
can create a PivotTable, or dynamic worksheet, that enables you to reorganize and filter 
your data on the fly. For instance, you can create a PivotTable with the same layout as 
the worksheet described previously, which emphasizes totals by month, and then change 
the PivotTable layout to have the rows represent the months of the year and the columns 
represent the distribution centers. The new layout emphasizes the totals by regional 
distribution center.
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To create a PivotTable, you must have your data collected in a list. Excel tables mesh 
perfectly with PivotTable dynamic views; not only do Excel tables have a well-defined 
column and row structure, but the ability to refer to an Excel table by its name also 
greatly simplifies PivotTable creation and management.

In the Excel table used to create the distribution PivotTable, each row of the table con-
tains a value representing the distribution center, date, month, week, weekday, day, and 
volume for every day of the years 2009 and 2010.

Excel needs that data when it creates the PivotTable so that it can maintain relation-
ships among the data. If you want to filter your PivotTable so that it shows all package 
volumes on Thursdays in January, for example, Excel must be able to identify January 11 
as a Thursday.

After you create an Excel table, you can click any cell in the table, display the Insert tab 
and then, in the Tables group, click PivotTable to open the Create PivotTable dialog box.



In this dialog box, you verify the data source for your PivotTable and whether you want to 
create a PivotTable on a new worksheet or an existing worksheet. After you click OK, Excel 
displays a new or existing worksheet and displays the PivotTable Field List task pane.

Tip	 You	should	always	place	your	PivotTable	on	its	own	worksheet	to	avoid	cluttering	the	
display.
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If the PivotTable Field List task pane isn’t visible, you can display it by clicking any cell in 
the PivotTable to display the PivotTable Tools contextual tabs. On the Options contextual 
tab, in the Show/Hide group, click Field List.

To assign a field, or column of data, to an area of the PivotTable, drag the field header 
from the Choose Fields To Add To Report area at the top of the PivotTable Field List task 
pane to the Drag Fields Between Areas Below area at the bottom of the task pane. For 
example, if you drag the Volume field header to the Values area, the PivotTable displays 
the total of all entries in the Volume column. 



It’s important to note that the order in which you enter the fields in the Row Labels 
and Column Labels areas affects how Excel organizes the data in your PivotTable. As an 
example, consider a PivotTable that groups the PivotTable rows by distribution center 
and then by month.
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The same PivotTable data could also be organized by month and then by distribution 
center.

In the preceding examples, all the field headers are in the Row Labels area. If you drag 
the Center header from the Row Labels area to the Column Labels area, the PivotTable 
reorganizes (pivots) its data to form a different configuration.



To pivot a PivotTable, you drag a field header to a new position in the PivotTable Field List 
task pane. As you drag a field within the task pane, Excel displays a blue line in the interior 
of the target area so you know where the field will appear when you release the left mouse 
button. If your data set is large or if you based your PivotTable on a data collection on 
another computer, it might take some time for Excel to reorganize the PivotTable after a 
pivot. You can have Excel delay redrawing the PivotTable by selecting the Defer Layout 
Update check box in the lower-left corner of the PivotTable Field List task pane. When 
you’re ready for Excel to display the reorganized PivotTable, click Update.

If you expect your PivotTable source data to change, such as when you link to an external 
database that records shipments or labor hours, you should ensure that your PivotTable 
summarizes all the available data. To do that, you can refresh the PivotTable connection 
to its data source. If Excel detects new data in the source table, it updates the PivotTable 
contents accordingly. To refresh your PivotTable, click any cell in the PivotTable and then, 
on the Options contextual tab, in the Data group, click Refresh.
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In this exercise, you’ll create a PivotTable by using data from a table, add fields to  
the PivotTable, and then pivot the PivotTable.

SET UP	 You	need	the	Creating_start	workbook	located	in	your	Chapter09	practice	
file	folder	to	complete	this	exercise.	Start	Excel,	open	the	Creating_start	workbook,	
and	save	it	as	Creating.	Then	follow	the	steps.	

	 1.	 Click any cell in the Excel table.

	 2.	 On the Insert tab, in the Tables group, click the PivotTable button (not the arrow).

The Create PivotTable dialog box opens.

	 3.	 Verify that the DailyVolumes table name appears in the Table/Range field and 
that the New Worksheet option is selected.

	 4.	 Click OK.

Excel creates a PivotTable on a new worksheet.

	 5.	 In the PivotTable Field List task pane, drag the Center field header to the Row 
Labels area.

Excel adds the Center field values to the PivotTable row area.



	 6.	 In the PivotTable Field List task pane, drag the Year field header to the Column 
Labels area.

Excel adds the Year field values to the PivotTable column area.

	 7.	 In the PivotTable Field List task pane, drag the Volume field header to the 
Values area.

Excel fills in the body of the PivotTable with the Volume field values.

	 8.	 In the PivotTable Field List task pane, in the Column Labels area, drag the 
Year field header to the Row Labels area, and drop it beneath the Center field 
header.

Excel changes the PivotTable to reflect the new organization.

CLEAN UP	 Save	the	Creating	workbook,	and	then	close	it.
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Filtering, Showing, and Hiding PivotTable Data
PivotTables often summarize huge data sets in a relatively small worksheet. The more 
details you can capture and write to a table, the more flexibility you have in analyzing 
the data. As an example, consider all the details captured in a table in which each row 
contains a value representing the distribution center, date, month, week, weekday, day, 
and volume for every day of the year.

Each column, in turn, contains numerous values: there are nine distribution centers, 
data from two years, 12 months in a year, seven weekdays, and as many as five weeks 
and 31 days in a month. Just as you can filter the data that appears in an Excel table 
or other data collection, you can filter the data displayed in a PivotTable by selecting 
which values you want the PivotTable to include.

See Also	 For	more	information	on	filtering	an	Excel	table,	see	“Limiting	Data	That	Appears	on	
Your	Screen”	in	Chapter	5,	“Focusing	on	Specific	Data	by	Using	Filters.”



To filter a PivotTable based on a field’s contents, click the field’s header in the Choose 
Fields To Add To Report area of the PivotTable Field List task pane. When you do, Excel 
displays a menu of sorting and filtering options.

The PivotTable displays several sorting options, commands for different categories of 
filters, and a list of items that appear in the field you want to filter. Every list item has a 
check box next to it. Items with a check mark in the box are currently displayed in the 
PivotTable, and items without a check mark are hidden. 

The first entry at the top of the item list is the Select All check box. The Select All check 
box can have one of three states: displaying a check mark, displaying a black square,  
or empty. If the Select All check box contains a check mark, then the PivotTable dis-
plays every item in the list. If the Select All check box is empty, then no filter items are 
selected. Finally, if the Select All check box contains a black square, it means that some, 
but not all, of the items in the list are displayed. Selecting only the Northwest check box, 
for example, leads to a PivotTable configuration in which only the data for the Northwest 
center is displayed.
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If you’d rather display as much PivotTable data as possible, you can hide the PivotTable 
Field List task pane and filter the PivotTable by using the filter arrows on the Row Labels 
and Column Labels headers within the body of the PivotTable. Clicking either of those 
headers enables you to select a field by which you can filter; you can then define the 
filter by using the same controls you see when you click a field header in the PivotTable 
Field List task pane.

Excel indicates that a PivotTable has filters applied by placing a filter indicator next to the 
Column Labels or Row Labels header, as appropriate, and the filtered field name in 
the PivotTable Field List task pane.



So far, all the fields by which we’ve filtered the PivotTable have changed the organiza-
tion of the data in the PivotTable. Adding some fields to a PivotTable, however, might 
create unwanted complexity. For example, you might want to filter a PivotTable by 
weekday, but adding the Weekday field to the body of the PivotTable expands the 
table unnecessarily.

Instead of adding the Weekday field to the Row Labels or Column Labels area, you can 
drag the field to the Report Filter area near the bottom of the PivotTable Field List task 
pane. Doing so leaves the body of the PivotTable unchanged, but adds a new area above 
the PivotTable in its worksheet.
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Tip	 In	Excel	2003	and	earlier	versions,	this	area	was	called	the	Page	Field	area.

When you click the filter arrow of a field in the Report Filter area, Excel displays a list of 
the values in the field. When you click the filter arrow, you can choose to filter by one 
value at a time. If you’d like to filter your PivotTable by more than one value, you can 
do so by selecting the Select Multiple Items check box.

If your PivotTable has more than one field in the Row Labels area, you can filter values 
in a PivotTable by hiding and collapsing levels of detail within the report. To do that, 
you click the Hide Detail control (which looks like a box with a minus sign in it) or the 
Show Detail control (which looks like a box with a plus sign in it) next to a header.  



For example, you might have your data divided by year; clicking the Show Detail control 
next to the 2009 year header would display that year’s details. Conversely, clicking the 
2010 year header’s Hide Detail control would hide the individual months’ values and 
display only the year’s total.

Excel 2010 provides two new ways for you to filter PivotTables: search filters and Slicers. 
With a search filter, you can type in a series of characters for Excel to filter that field’s 
values. To create a search filter, click a field’s filter arrow and type the character string 
for which you want to search in the filter menu’s Search box.
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For example, if the PivotTable’s Center field contains the values Atlantic, Central, Midwest, 
Mountain West, North Central, Northeast, Northwest, Southeast, and Southwest, typing 
the character string “No” limits the values to North Central, Northeast, and Northwest.

Tip	 Search	filters	look	for	the	character	string	you	specify	anywhere	within	a	field’s	value,	
not	just	at	the	start	of	the	value.	In	the	previous	example,	the	search	filter	string	“cen”	would	
return	both	Central	and	North Central.

In versions of Excel prior to Excel 2010, the only visual indication that you had applied a 
filter to a field was the indicator added to a field’s filter arrow. The indicator told users  
that there was an active filter applied to that field but provided no information on 
which values were displayed and which were hidden. In Excel 2010, Slicers provide a 
visual indication of which items are currently displayed or hidden in a PivotTable. 



To create a Slicer, click any cell in a PivotTable and then, on the Options contextual tab 
of the ribbon, in the Sort & Filter group, click Insert Slicer to display the Insert Slicers 
dialog box.

Select the check box next to the fields for which you want to create a Slicer, and click OK. 
When you do, Excel 2010 displays a Slicer for each field you identified.
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Tip	 If	you	have	already	applied	a	filter	to	the	field	for	which	you	display	a	Slicer,	the	Slicer	
reflects	the	filter’s	result.

A Slicer displays the values within the PivotTable field you identified. Any value displayed in 
color (or gray if you select a gray-and-white color scheme) appears within the PivotTable. 
Values displayed in light gray or white do not appear in the PivotTable. 

Clicking an item in a Slicer changes that item’s state—if a value is currently displayed in 
a PivotTable, clicking it hides it. If it’s hidden, clicking its value in the Slicer displays it 
in the PivotTable. As with other objects in an Excel 2010 workbook, you can use the Shift 
and Ctrl keys to help define your selections. For example, suppose you create a Slicer for 
the Month field while every month is displayed.



If you want to hide every month except January, February, and March, you click the 
January item to hide every month except January. Then hold down the Shift key 
and click March to have Excel 2010 display just the data for the months of January, 
February, and March. You can then add another month, such as July, to the filter by 
holding down the Ctrl key and clicking July in the Slicer.
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To use a Slicer to remove a filter, click the Clear Filter button in the upper-right corner of 
the Slicer. If you want to resize a Slicer, you can do so by dragging the resize handle in the 
lower-right corner of the Slicer. To hide the Slicer, right-click it and then click the menu 
command that starts with the word “Remove.” For example, the Month field’s menu com-
mand would be Remove Month.

Tip	 You	can	change	a	Slicer’s	formatting	by	clicking	the	Slicer	and	then,	on	the	Slicer	Tools	
Options	contextual	tab	on	the	ribbon,	clicking	a	style	in	the	Slicer	Styles	gallery.

In this exercise, you’ll focus the data displayed in a PivotTable by creating a filter, by filter-
ing a PivotTable based on the contents of a field in the Report Filters area, by showing and 
hiding levels of detail within the body of the PivotTable, by using the Search box, and by 
using Slicers.

SET UP	 You	need	the	Focusing_start	workbook	located	in	your	Chapter09	practice	
file	folder	to	complete	this	exercise.	Open	the	Focusing_start	workbook,	and	save	it	
as	Focusing.	Then	follow	the	steps.	

	 1.	 On the Sheet2 worksheet, click any cell in the PivotTable.

	 2.	 In the PivotTable Field List task pane’s Choose fields to add to report area, 
click the Center field header, click the Center field filter arrow, and then clear the 
(Select All) check box.



Excel clears all the check boxes in the filter menu.

	 3.	 Select the Northwest check box, and then click OK.

Excel filters the PivotTable.

	 4.	 On the Quick Access Toolbar, click the Undo button.

Excel removes the filter.

	 5.	 In the PivotTable Field List task pane, drag the Weekday field header from the 
Choose fields to add to report area to the Report Filter area in the Drag fields 
between areas below area.

	 6.	 In the PivotTable Field List task pane, click the Close button.

The PivotTable Field List task pane closes.

	 7.	 In the body of the worksheet, click the Weekday filter arrow, and then, if necessary, 
select the Select Multiple Items check box.

Excel adds check boxes beside the items in the Weekday field filter list.

	 8.	 Clear the All check box.

Excel clears each check box in the list.
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	 9.	 Select the Tuesday and Thursday check boxes, and then click OK.

Excel filters the PivotTable, summarizing only those values from Tuesdays and 
Thursdays.

	 10.	 In cell A5, click the Hide Detail button.

Excel collapses rows that contain data from the year 2009, leaving only the subtotal 
row that summarizes that year’s data.

	 11.	 In cell A5, click  the Show Detail button.

Excel redisplays the collapsed rows.

	 12.	 On the ribbon, click the Options contextual tab, and then, in the Show group, click 
Field List.

The PivotTable Field List task pane opens.

	 13.	 In the PivotTable Field List task pane, click the Month field header arrow.

The filter menu opens.



	 14.	 In the Search box, type Ju.

Excel displays the months June and July in the filter list.

	 15.	 Click OK.

Excel applies the filter.

	 16.	 On the Options contextual tab of the ribbon, in the Actions group, click the Clear 
button, and then click Clear Filters.

Excel clears all filters from the PivotTable.

	 17.	 On the Options contextual tab of the ribbon, in the Sort & Filter group, click 
Insert Slicer.

The Insert Slicers dialog box opens.

	 18.	 In the Insert Slicers dialog box, select the Center check box, and then click OK.

A Slicer for the Center field appears.

	 19.	 Click the Atlantic item.

Excel filters the PivotTable so only results for the Atlantic center appear.
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	 20.	 In the Slicer, click Midwest, and then, while holding down the Ctrl key, click 
Mountain West and then Northwest.

Excel filters the PivotTable so it displays results for the Midwest, Mountain West, 
and Northwest centers.

	 21.	 In the upper-right corner of the Slicer, click the Clear Filter button.

Excel removes the filter from the Center field.

	 22.	 Right-click the Slicer, and then click Remove "Center".

Excel closes the Slicer.

CLEAN UP	 Save	the	Focusing	workbook,	and	then	close	it.

Editing PivotTables
After you create a PivotTable, you can rename it, edit it to control how it summarizes your 
data, and use the PivotTable cell data in a formula. As an example, consider a PivotTable 
named PivotTable2 that summarizes package volumes for every Consolidated Messengers 
regional distribution hub.



Excel displays the PivotTable name on the Options contextual tab, in the PivotTable 
Options group. The name PivotTable2 doesn’t help you or your colleagues understand 
the data the PivotTable contains, particularly if you use the PivotTable data in a formula 
on another worksheet. To give your PivotTable a more descriptive name, click any cell in 
the PivotTable and then, on the Options contextual tab, in the PivotTable Options group, 
type the new name in the PivotTable Name field.

When you create a PivotTable with at least one field in the Row Labels area and one field 
in the Column Labels area of the PivotTable Field List task pane, Excel adds a grand total 
row and column to summarize your data. You can control how and where these sum-
mary rows and columns appear by clicking any PivotTable cell and then, on the Design 
contextual tab, in the Layout group, clicking either the Subtotals or Grand Totals button 
and selecting the desired layout.

After you create a PivotTable, Excel determines the best way to summarize the data in the 
column you assign to the Values area. For numeric data, for example, Excel uses the SUM 
function. If you want to change a PivotTable summary function, right-click any data cell in 
the PivotTable values area, point to Summarize Values By, and then click the desired opera-
tion. If you want to use a function other than those listed, click More Options to display the 
Value Field Settings dialog box. On the Summarize Values By page of the dialog box, you 
can choose the summary operation you want to use.
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You can also change how the PivotTable displays the data in the Values area. On the Show 
Values As page of the Value Field Settings dialog box, you can select whether to display 
each cell’s percentage contribution to its column’s total, its row’s total, or its contribution 
to the total of all values displayed in the PivotTable.

If you want, you can create a formula that incorporates a value from a PivotTable cell. 
To do so, you click the cell where you want to create the formula, type an equal sign, 
and then click the cell in the PivotTable that contains the data you want to appear in the 
other cell. A GETPIVOTDATA formula appears in the formula box of the worksheet that 
contains the PivotTable. When you press Enter, Excel creates the GETPIVOTDATA formula 
and displays the contents of the PivotTable cell in the target cell.



In this exercise, you’ll rename a PivotTable, specify whether subtotal and grand total rows 
will appear, change the PivotTable summary function, display each cell’s contribution to 
its row’s total, and create a formula that incorporates a value in a PivotTable cell.

SET UP	 You	need	the	Editing_start	workbook	located	in	your	Chapter09	practice	
file	folder	to	complete	this	exercise.	Open	the	Editing_start	workbook,	and	save	it	
as	Editing.	Then	follow	the	steps.

	 1.	 On the Sheet2 worksheet, click any cell in the PivotTable.

	 2.	 On the Options contextual tab, in the PivotTable group, in the PivotTable Name 
field, type VolumeSummary and press Enter.

Excel renames the PivotTable.

	 3.	 On the Design contextual tab, in the Layout group, click Subtotals, and then click 
Do Not Show Subtotals.

Excel removes the subtotal rows from the PivotTable.

	 4.	 On the Design contextual tab, in the Layout group, click Grand Totals, and then 
click On for columns only.

Excel removes the cells that calculate each row’s grand total.
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	 5.	 On the Quick Access Toolbar, click the Undo button.

Excel reverses the last change.

	 6.	 Right-click any data cell in the PivotTable, point to Summarize Values By, and then 
click Average.

Excel changes the Value field summary operation.

	 7.	 On the Quick Access Toolbar, click the Undo button.

Excel reverses the last change.

	 8.	 Right-click any data cell in the PivotTable, and then click Value Field Settings.

The Value Field Settings dialog box opens.

	 9.	 Click the Show Values As tab.

The Show Values As page appears.

	 10.	 In the Show Values As list, click % of Row Total.

	 11.	 Click OK.

Excel changes how it calculates the values in the PivotTable.



	 12.	 On the Quick Access Toolbar, click the Undo button.

Excel reverses the last change.

	 13.	 On the Design tab, in the Layout group, click Subtotals, and then click Show All 
Subtotals at Bottom of Group.

Excel displays subtotals in the workbook.

	 14.	 Click the Package Summary sheet tab.

The Package Summary worksheet appears.

	 15.	 In cell C4, type =, but do not press Enter.

	 16.	 Click the PivotTable sheet tab.

The PivotTable worksheet appears.

	 17.	 Click cell K32, and then press Enter.

Excel creates the formula =GETPIVOTDATA(“Volume”,PivotTable!$A$3,”Year”,2010) 
in cell C4.
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CLEAN UP	 Save	the	Focusing	workbook,	and	then	close	it.

Formatting PivotTables
PivotTables are the ideal tools for summarizing and examining large data tables, even 
those containing more than 10,000 or even 100,000 rows. Even though PivotTables often 
end up as compact summaries, you should do everything you can to make your data more 
comprehensible. One way to improve your data’s readability is to apply a number format 
to the PivotTable Values field. To apply a number format to a field, right-click any cell in the 
field, and then click Number Format to display the Format Cells dialog box. Select or define 
the format you want to apply, and then click OK to enact the change.

See Also	 For	more	information	on	selecting	and	defining	cell	formats	by	using	the	Format	
Cells	dialog	box,	see	“Formatting	Cells”	in	Chapter	4,	“Changing	Workbook	Appearance.”

Analysts often use PivotTables to summarize and examine organizational data with an 
eye to making important decisions about the company. For example, chief operating 
officer Lori Penor might examine monthly package volumes handled by Consolidated 
Messenger and notice that there’s a surge in package volume during the winter months 
in the United States.



Excel extends the capabilities of your PivotTables by enabling you to apply a conditional 
format to the PivotTable cells. What’s more, you can select whether to apply the condi-
tional format to every cell in the Values area, to every cell at the same level as the selected 
cell (that is, a regular data cell, a subtotal cell, or a grand total cell) or to every cell that 
contains or draws its values from the selected cell’s field (such as the Volume field in the 
previous example).

To apply a conditional format to a PivotTable field, click a cell in the Values area. On the 
Home tab, in the Styles group, click Conditional Formatting, and then create the desired 
conditional format. After you do, Excel displays a Formatting Options action button, 
which offers three options for applying the conditional format:

●	 Selected	Cells	 Applies the conditional format to the selected cells only

●	 All	Cells	Showing	Sum	of	field_name	Values	 Applies the conditional format to every 
cell in the data area, regardless of whether the cell is in the data area, a subtotal row 
or column, or a grand total row or column

●	 All	Cells	Showing	Sum	of	field_name	Values	for	Fields	 Applies the conditional 
format to every cell at the same level (for example, data cell, subtotal, or grand 
total) as the selected cells
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See Also	 For	more	information	on	creating	conditional	formats,	see	“Changing	the	
Appearance	of	Data	Based	on	Its	Value”	in	Chapter	4,	“Changing	Workbook	Appearance.”

In Excel, you can take full advantage of the Microsoft Office system enhanced formatting 
capabilities to apply existing formats to your PivotTables. Just as you can create Excel 
table formats, you can also create your own PivotTable formats to match your organi-
zation’s desired color scheme.

To apply a PivotTable style, click any cell in the PivotTable and then, on the Design con-
textual tab, in the PivotTable Styles group, click the gallery item representing the style 
you want to apply. If you want to create your own PivotTable style, click the More button 
in the PivotTable Styles gallery (in the lower-right corner of the gallery), and then click 
New PivotTable Style to display the New PivotTable Quick Style dialog box.

Type a name for the style in the Name field, click the first table element you want to cus-
tomize, and then click Format. Use the controls in the Format Cells dialog box to change 
the element’s appearance. After you click OK to close the Format Cells dialog box, the New 
PivotTable Quick Style dialog box Preview pane displays the style’s appearance. If you want 
Excel to use the style by default, select the Set As Default PivotTable Quick Style For This 
Document check box. After you finish creating your formats, click OK to close the New 
PivotTable Quick Style dialog box and save your style.



The Design contextual tab contains many other tools you can use to format your PivotTable, 
but one of the most useful is the Banded Columns check box, which you can find in the 
PivotTable Style Options group. If you select a PivotTable style that offers banded rows as 
an option, selecting the Banded Rows check box turns banding on. If you prefer not to have 
Excel band the rows in your PivotTable, clearing the check box turns banding off.

In this exercise, you’ll apply a number format to a PivotTable values field, apply a PivotTable 
style, create your own PivotTable style, give your PivotTable banded rows, and apply a con-
ditional format to a PivotTable.

SET UP	 You	need	the	Formatting_start	workbook	located	in	your	Chapter09	practice	
file	folder	to	complete	this	exercise.	Open	the	Formatting_start	workbook,	and	save	it	
as	Formatting.	Then	follow	the	steps.	

	 1.	 On the Sheet2 worksheet, right-click any data cell, and then click Number Format.

The Format Cells dialog box opens.

	 2.	 In the Category list, click Number.

The Number page is displayed.
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	 3.	 In the Decimal places field, type 0.

	 4.	 Select the Use 1000 Separator (,) check box.

	 5.	 Click OK.

Excel reformats your PivotTable data.

	 6.	 If necessary, on the Design contextual tab, in the PivotTable Style Options group, 
select the Banded Rows check box.

	 7.	 On the Design contextual tab, in the PivotTable Styles group, click the More 
button. Then, in the top row of the gallery, click the third style from the left. 
(When you point to it, Excel displays a ScreenTip that reads Pivot Style Light 2.)



Excel applies the PivotTable style.

	 8.	 In the lower-right corner of the PivotTable Styles gallery, click the More button.

The gallery expands.

	 9.	 Click New PivotTable Style.

The New PivotTable Quick Style dialog box opens.

	 Formatting	PivotTables	 	 247



248  	 Chapter	9	 Creating	Dynamic	Worksheets	by	Using	PivotTables

	 10.	 In the Name field, type Custom Style 1.

	 11.	 In the Table Element list, click Header Row, and then click Format.

The Format Cells dialog box opens.

	 12.	 On the Font page, in the Color list, click the white square.

	 13.	 On the Border page, in the Presets area, click Outline.

	 14.	 On the Fill page, in the Background Color area, click the purple square at the 
lower-right corner of the color palette.

	 15.	 Click OK.

The Format Cells dialog box closes, and the style change appears in the Preview 
pane of the New PivotTable Quick Style dialog box.

	 16.	 In the Table Element list, click Second Row Stripe, and then click Format.

The Format Cells dialog box opens.

	 17.	 On the Fill page, in the middle part of the Background Color area, click the 
eighth square in the second row (it’s a light, dusty purple).

	 18.	 Click OK twice.



The Format Cells dialog box closes, and your format appears in the PivotTable 
Styles gallery.

	 19.	 Click the new style.

Excel formats your PivotTable using your custom PivotTable style.

	 20.	 On the Design contextual tab, in the PivotTable Style Options group, clear the 
Banded Rows check box.

Excel removes the banding from your PivotTable and from the preview of the 
custom style.
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	 21.	 Select the cell ranges K6:K17 and K19:K30.

	 22.	 On the Home tab, in the Styles group, click Conditional Formatting, point to 
Color Scales, and in the top row, click the second three-color scale from the left.

Excel applies the conditional format to the selected cells.

CLEAN UP	 Save	the	Formatting	workbook,	and	then	close	it.

Creating PivotTables from External Data
Although most of the time you will create PivotTables from data stored in Excel worksheets, 
you can also bring data from outside sources into Excel. For example, you might need 
to work with data created in another spreadsheet program with a file format that Excel 
can’t read directly. Fortunately, you can export the data from the original program into a 
text file, which Excel then translates into a worksheet.



Tip	 The	data	import	technique	shown	here	isn’t	exclusive	to	PivotTables.	You	can	use	this	
procedure	to	bring	data	into	your	worksheets	for	any	purpose.

Spreadsheet programs store data in cells, so the goal of representing spreadsheet data in 
a text file is to indicate where the contents of one cell end and those of the next cell begin. 
The character that marks the end of a cell is a delimiter, in that it marks the end (or “limit”) 
of a cell. The most common cell delimiter is the comma, so the delimited sequence 15, 18, 
24, 28 represents data in four cells. The problem with using commas to delimit financial 
data is that larger values—such as 52,802—can be written by using commas as thousands 
markers. To avoid confusion when importing a text file, the most commonly used delimiter 
for financial data is the Tab character.

To import data from a text file, on the Data tab, in the Get External Data group, click 
From Text to display the Import Text File dialog box.
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From within the Import Text File dialog box, browse to the directory that contains  
the text file you want to import. Double-clicking the file launches the Text Import 
wizard.

On the first page of the Text Import wizard, you can indicate whether the data file you 
are importing is Delimited or Fixed Width; Fixed Width means that each cell value will fall 
within a specific position in the file. Clicking Next to accept the default choice, Delimited 
(which Excel assigns after examining the data source you selected), advances you to the 
next wizard page.



On this page, you can choose the delimiter for the file (in this case, Excel detected tabs in 
the file and selected the Tab check box for you) and gives you a preview of what the text 
file will look like when imported. Clicking Next advances you to the final wizard page.
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On this page, you can change the data type and formatting of the columns in your data. 
Because you’ll assign number styles and PivotTable Quick Styles after you create the 
PivotTable, you can click Finish to import the data into your worksheet. After the data is 
in Excel, you can work with it normally.

In this exercise, you’ll import data into Excel from a text file and then create a PivotTable 
based on that data.

SET UP	 You	need	the	Creating_start	text	file	located	in	your	Chapter09	practice	file	
folder	to	complete	this	exercise.	

	 1.	 Create a new Excel workbook. On the Data tab, click the Get External Data button, 
and then click From Text.

The Import Text File dialog box opens.

	 2.	 Navigate to the Chapter09 practice file folder, and then double-click 
Creating_start.txt.

The Text Import wizard starts.

	 3.	 Verify that the Delimited option is selected, and then click Next.

The next Text Import Wizard page opens.

	 4.	 In the Delimiters area, verify that the Tab check box is selected and also verify 
that the data displayed in the Data preview area reflects the structure you 
expect.

	 5.	 Click Finish.

Clicking Finish skips page 3 of the wizard, which has commands you can use 
to assign specific data types to each column. Excel assigns data types for you, 
so you don’t need to do so. After you click Finish, the Import Data dialog box 
opens.



	 6.	 Verify that the Existing worksheet option is selected, and then click OK.

Excel imports the data into your workbook.

	 7.	 On the Home tab, in the Styles group, click Format as Table, and then click the 
first table style.

The Format As Table dialog box opens.

	 8.	 Verify that the My table has headers check box is selected and that the range 
=$A$1:$H$6571 appears in the Where is the data for your table? box, and 
then click OK.

A confirmation dialog box opens.

	 9.	 Click Yes to confirm you want to create the Excel table and break its link to the 
external data source.

Excel creates an Excel table from your imported data.

	 10.	 On the Insert tab, in the Tables group, click PivotTable.

The Create PivotTable dialog box opens.

	 11.	 Verify that the Select a table or range option is selected, that Table1 appears in 
the Table/Range field, and that the New Worksheet option is selected.

	 12.	 Click OK.

Excel creates the PivotTable on a new worksheet.

	 13.	 In the PivotTable Field List task pane, drag the Volume field header to the 
Values area.

	 14.	 Drag the Weekday field header to the Column Labels area.

	 15.	 Drag the Center field header to the Row Labels data area.
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	 16.	 On the Quick Access Toolbar, click the Save button.

The Save As dialog box opens.

	 17.	 Browse to the Chapter09 folder.

	 18.	 In the File name field, type ImportedData.

	 19.	 Click Save.

Excel saves your file.

CLEAN UP	 Close	the	Imported	Data	workbook.	If	you’re	not	continuing	directly	to	
the	next	chapter,	exit	Excel.



Key Points
● A PivotTable is a versatile tool you can use to rearrange your data dynamically, 

enabling you to emphasize different aspects of your data without creating new 
worksheets.

● PivotTable data must be formatted as a list. By using a data table as the PivotTable 
data source, you can streamline the creation process by referring to the table name 
instead of being required to select the entire range that contains  
the data you want to summarize.

● Excel comes with many attractive styles for PivotTables; you’ll probably find one 
you like.

● With the PivotTable Field List task pane, you can create your PivotTable by using 
a straightforward, compact tool.

● Just as you can limit the data shown in a static worksheet, you can use filters to 
limit the data shown in a PivotTable.

● Excel 2010 includes two new types of filters, search filters and Slicers, that you can 
use to limit the data in your PivotTables.

● If you have data in a compatible format, such as a text file, you can import that 
data into Excel and create a PivotTable from it.
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